Flasher

The venerable workhorse - Got trouble?, Post a question here.

Moderator: The Moderators

Flasher

Postby SidVecory » Fri 09 Dec 2011 6:07 pm

After fixing my heater matrix and refitting the dash, everything is working fine except that the green warning light, that flashes with the indicator light when a trailer is fitted, is permanently on. The wiring diagram appears to show the connections going to the flasher unit. Could this be the problem ? (and where exactly is it ?).
Discovery 1 300TDi XS 170,000 miles and rising
"It's no use saying 'We are doing our best'. We have got to succeed in doing what is necessary" - Winston Churchill
SidVecory
Spanner man
 
Posts: 191
Joined: Mon 22 Nov 2010 11:59 pm
Location: 'aampsher

Re: Flasher

Postby Paul 94 200 TDI dicso » Fri 09 Dec 2011 6:24 pm

Had exactly the same on my 200 tdi (I think) indicaters work but no indication on the dash, trailor indicator flashes once,

It was the relay, and on a 200 tdi it's by the steering wheel shaft under the fuse box cover
ImageImageImageImage
User avatar
Paul 94 200 TDI dicso
Living in the past
 
Posts: 18245
Joined: Sun 10 Jun 2007 5:19 pm
Location: 52428 Germany

Re: Flasher

Postby discool » Fri 09 Dec 2011 7:09 pm

On a 300 series the flasher unit is pluged into the fuse board to the right of the steering wheel.
1997 Discovery ES V8 auto.
Previously for 10 years: 1987 Range Rover Vogue Efi auto.
Previously for 2 years 1985 TVR 350i manual.

STAY FROSTY & USE LOGIC ON DIFFICULT JOBS - Get someone else to do it..
User avatar
discool
Head suit
 
Posts: 3716
Joined: Mon 19 Mar 2007 10:02 am
Location: Kent, The Garden of England.

Re: Flasher

Postby SidVecory » Fri 09 Dec 2011 9:28 pm

Thanks chaps, I'll have a poke around in the morning and let you know how I get on :wink:
Discovery 1 300TDi XS 170,000 miles and rising
"It's no use saying 'We are doing our best'. We have got to succeed in doing what is necessary" - Winston Churchill
SidVecory
Spanner man
 
Posts: 191
Joined: Mon 22 Nov 2010 11:59 pm
Location: 'aampsher

Re: Flasher

Postby buzziesrme » Sun 11 Dec 2011 6:39 pm

I had dodgy indicators once, nearly ripped the dash appart to solve it. Turned out to be the hazards that were interfering with the indicators. I had just used the hazards before the fault. I pushed the hazard switch a couple of times on and off and it fixed the problem :shock:
If at first you don't succeed, destroy all evidence that you tried
User avatar
buzziesrme
Member Of Forum Elite
 
Posts: 1332
Joined: Thu 15 Nov 2007 7:55 pm
Location: Poulton-Le-Fylde


Return to Discovery 1

Who is online

Users browsing this forum: No registered users and 1 guest