New Td5 Clutch Problem

This is the place to find and to give Discovery advice. To post a question you'll need to register first. Any adverts will be removed with out notice.

Moderator: The Moderators

New Td5 Clutch Problem

Postby Hawkertempest » Tue 23 Dec 2008 11:41 pm

Help...........
I have just fitted a new Clutch assy including dual mass flywheel.
Had trouble getting the air out when bleeding.
After much frustration replaced Master Cylinder and slave cylinder.
Reverse bled system again and I am still having problems getting into reverse and sometimes "crunch" other gears.
All parts are new genuine land rover.
The only thing I haven't done is change the transmission oil.
:oops:
[b]Td5 Man
Alive Stage 2 Tune, Snkl, QT Diff Grds, Mantec Strg Guard, CDL,QT HD Drag Link, HD Track Rod, 3 deg Rad Arm, QT Adjustable Panhard Rod, OME Strg Dpr, QT Strg Dpr Mnt, HD Shock Turts, OME 2" HD Coil Spr Lift with OME HD Nitrochrgr Spt Shks, ARB Sahara Bar, Winch, Tom Wood Prop Shaft
Hawkertempest
Grease Monkey
 
Posts: 59
Joined: Mon 18 Aug 2008 5:05 am
Location: New Zealand

Postby Les Henson » Wed 24 Dec 2008 8:55 am

Did you put the plate on the right way round? It will fit on either way, but drags when you try to change gear. These clutches also need to settle in and the ones I have done always need to be driven for a while before the clutch works properly.


Les.
Les Henson
Head suit
 
Posts: 397
Joined: Fri 05 Oct 2007 11:26 am
Location: swindon,wiltshire

Postby martinhollings » Wed 24 Dec 2008 6:22 pm

i had this problem a month or two back put loads of brake fluid threw to try and blead it turn out that the friciton plate was twisted it was the 3rd time of having the gearbox out that i found it
ImageImage
User avatar
martinhollings
Head suit
 
Posts: 2000
Joined: Thu 01 Mar 2007 8:04 pm
Location: newark/nottingham


Return to Discovery

Who is online

Users browsing this forum: Google [Bot] and 1 guest